Вопрос по анимации - Форум - Все для Unity3d

Все для Unity3d> Вопрос по анимации - Форум>
Страница 1 из 11
Форум » Unity » Вопросы » Вопрос по анимации
Вопрос по анимации
Predator2651Дата: Воскресенье, 06.07.2014, 13:49 | Сообщение # 1
Новый писатель
Группа: Пользователи
Сообщений: 4
Статус: Offline
Вот дошли мои руки до Mecanim .Делал всё по урокам Беляева Валерия.Там он говорит что лучше передвигать персонажа анимацией а не скриптом я сделал все анимации но во время проигрывания персонаж делает два шага из исходной точки,затем попадает в эту же исходную точку из которой вышел и так все время, а в уроках персонаж нормально ходит,так же с анимациями подката , и передвижения влево и вправо.Заранее благодарю за ответ smile .
 
Salavan73Дата: Понедельник, 07.07.2014, 11:23 | Сообщение # 2
Новый писатель
Группа: Заблокированные
Сообщений: 22
Статус: Offline
Значит либо кадр пропущен или что-то.
 
PetrTzarevRUSДата: Понедельник, 07.07.2014, 13:38 | Сообщение # 3
Новый писатель
Группа: Пользователи
Статус: Offline
попробуй использовать оффицальнай пример из ассет сторе от unity tehnolages
 
ArtSuperДата: Понедельник, 07.07.2014, 20:16 | Сообщение # 4
Новый писатель
Группа: Пользователи
Сообщений: 24
Статус: Offline
Цитата Predator2651 ()
Там он говорит что лучше передвигать персонажа анимацией а не скриптом я сделал все анимации но во время проигрывания персонаж делает два шага из исходной точки,затем попадает в эту же исходную точку из которой вышел и так все время, а в уроках персонаж нормально ходит,так же с анимациями подката
Может ты перепутал во вкладке персонажа RIG/Avatar Definition > Нужно выбрать что-то связанное с моделью
 
Predator2651Дата: Среда, 09.07.2014, 13:46 | Сообщение # 5
Новый писатель
Группа: Пользователи
Сообщений: 4
Статус: Offline
Спасибо за большое кол-во ответов , кадр не пропущен , аватар стоит тот который и нужен, проблема бы наверно в том что у меня не человекоподобная модель у нее волосы на костях и на груди пластины костями двигались , вобщем cyber sub-zero из MK9 , поставил тип анимации на gumanoid модель двигается но меш исчезает , кто нибудь с таким сталкивался?
 
ArtSuperДата: Среда, 09.07.2014, 20:12 | Сообщение # 6
Новый писатель
Группа: Пользователи
Сообщений: 24
Статус: Offline
Цитата Predator2651 ()
Спасибо за большое кол-во ответов , кадр не пропущен , аватар стоит тот который и нужен, проблема бы наверно в том что у меня не человекоподобная модель у нее волосы на костях и на груди пластины костями двигались , вобщем cyber sub-zero из MK9 , поставил тип анимации на gumanoid модель двигается но меш исчезает , кто нибудь с таким сталкивался?
Я делал с руками, все отлично пашет)))
//Mecanim рулит)))
 
Форум » Unity » Вопросы » Вопрос по анимации
Страница 1 из 11
Поиск:
Свернуть
Развернуть
Необходима авторизация
0
ТОП-5 САЙТА
НОВЫЕ ИГРЫ
ГОРЯЧИЕ ТЕМЫ
СЛУЧАЙНЫЕ ФАЙЛЫ