Проблема включения анимации - Форум - Все для Unity3d

Все для Unity3d> Проблема включения анимации - Форум>
Страница 1 из 11
Форум » Unity » Вопросы » Проблема включения анимации
Проблема включения анимации
bulletoneДата: Суббота, 03.05.2014, 11:31 | Сообщение # 1
Новый писатель
Группа: Пользователи
Статус: Offline
Всем привет.
Подскажите кто знает...есть моделька человека с анимацией (просто минимальное  движение руки) сделан в zbrush. Переношу его в Unity и как известно надо в RIG выставлять тип Legacy и потом только настраивать анимацию. Как только включаю это тип все сцена начинает жутко тормозить но и рука у модели начинает двигаться...что бы было понятно вся сцена летает ни чего не перегружено но падает зараза до 3-5 fps при включении Legacy.
Заранее Спасибо.
 
devpilgrimДата: Суббота, 03.05.2014, 11:41 | Сообщение # 2
Начинающий писатель
Группа: Проверенные
Сообщений: 196
Статус: Offline
Цитата bulletone ()
что бы было понятно вся сцена летает ни чего не перегружено но падает зараза до 3-5 fps при включении Legacy.
тип анимации в ролике не должен влиять на производительность... Ну никак вообще. Сотрите скрипты которые связаны с анимацией, скорее всего ошибка именно в них. Вполне возможно где-то проблемы с появлением больших циклов...
Ну или еще проблемы могут быть при очень плотных сетках модели. При статическом отображении - будет все летать (особенно если делалась оптимизация меша), а вот при воспроизведении анимации будут большие проблемы...
А вообще, нужно видеть модель, саму анимацию и саму сцену, может тогда и получится найти ответ, а так - это гадание на кофейной гуще..


Готов работать за деньги, или за очень большие деньги.
 
bulletoneДата: Суббота, 03.05.2014, 14:11 | Сообщение # 3
Новый писатель
Группа: Пользователи
Статус: Offline
умм хорошо я все перепроверю..если что покажу модель
 
Форум » Unity » Вопросы » Проблема включения анимации
Страница 1 из 11
Поиск:
Свернуть
Развернуть
Необходима авторизация
0
ТОП-5 САЙТА
НОВЫЕ ИГРЫ
ГОРЯЧИЕ ТЕМЫ
СЛУЧАЙНЫЕ ФАЙЛЫ